17. EIGRP (Enhanced Interior Gateway Protocol)

Screenshot 89 1

Bid TIK Polda Kepri

Overview

  • Hello packet dikirimkan setiap 5 detik dengan dead time 15 detik.
  • Alamat tujuan untuk pengiriman hello packet adalah 224.0.0.10.
  • Dalam bertukar informasi, parameter EIGRP yang harus sama yaitu:
    • Authentication Key
    • AS Number
    • IP Address pengirim pada hello packet harus sama dengan subnet interface dimana hello packet diterima.
  • Jalur terpendek akan ditempatkan pada tabel routing. Jalur terpendek ditentukan berdasarkan metric.
  • Metric EIGRP:
    • MTU
    • Load
    • Reliability
    • Bandwidth
    • Delay
      Karena MTU, Load dan Reliability memiliki nilai faktor parameter 0, maka yang akan dihitung hanya Bandwidth dan Delay.
  • Di dalam router, parameter bandwidth dapat dirubah dan mempengaruhi perhitungan metric EIGRP. Tetapi tidak berpengaruh pada real bandwidth pada interface.

Praktik EIGRP

Screenshot 89
EIGRP dan RIP

Pada topologi di atas, network yang berwarna hijau menjalankan protokol EIGRP. Dan yang berwarna biru menjalankan RIP. Keduanya dapat di redistribute.

R1(config)# router eigrp 100
R1(config-router)# no auto-summary
R1(config-router)# network 12.12.12.0
R1(config-router)# network 13.13.13.0

R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# no auto-summary
R1(config-router)# network 14.14.14.0
R2(config)# router eigrp 100
R2(config-router)# no auto-summary
R2(config-router)# network 12.12.12.0
R2(config-router)# network 23.23.23.0
R2(config-router)# network 2.2.2.0
R3(config)# router eigrp 100
R3(config-router)# no auto-summary
R3(config-router)# network 13.13.13.0
R3(config-router)# network 23.23.23.0
R3(config-router)# network 3.3.3.0
R4(config)# router rip
R4(config-router)# version 2
R4(config-router)# no auto-summary
R4(config-router)# network 14.14.14.0
R4(config-router)# network 4.4.4.0

Untuk melakukan redistribute EIGRP dan RIP:

R1(config)# router eigrp 100
R1(config-router)# redistribute rip metric 1 1 1 1 1

1 1 1 1 1 menandakan metric EIGRP yaitu MTU, Load, Reliability, Bandwidth dan Delay.

R1(config)# router rip
R1(config-router)# redistribute eigrp 100 metric 1

metric 1 menandakan metric untuk RIP yaitu jumlah hop.

Lakukan tes ping pada area EIGRP maupun dari EIGRP ke RIP. Periksa pada tabel routing R2 apakah protokol RIP sudah masuk ke EIGRP.

Screenshot 87
ip route eigrp

Kode D EX menandakan bahwa network 4.4.4.0 dan 14.14.14.0 yang menjalankan protokol router RIP sudah masuk ke dalam tabel routing EIGRP. Periksa juga pada R4 apakah protokol EIGRP sudah masuk ke tabel routing RIP.

Screenshot 88
ip route rip

LANJUTKAN BACA MATERI LENGKAP